Package ca.marcusdunn.jsonlens.testkit
@NullMarked
package ca.marcusdunn.jsonlens.testkit
Tests for a JsonModel: a verifier of the model rules, contract tests, and the RFC test suites.
-
ClassDescriptionRuns the test suites of RFC 9535 and RFC 6902 on a model, as JUnit dynamic tests.Tests that a model that also implements
JsonEditoris well-formed: each change gives the expected value, each method returns the value that it replaced or removed, and the reverse changes give the original value again.Tests that a model that also implementsJsonFactoryis well-formed: each built node has the correct kind, and the read methods give the exact value again.Tests that aJsonModelobeys its contract, as JUnit tests.Makes random JSON texts (RFC 8259) from a seed.A rule of theJsonModelcontract thatModelVerifierchecks.A value of a document that breaks aRule.